| #!/usr/bin/make -f |
| # -*-makefile-*- |
| # based on the sample debian/rules file for GNU hello by Ian Jackson. |
| |
| package=grub |
| |
| INSTALL = install -c |
| INSTALL_DATA = $(INSTALL) -m 644 |
| INSTALL_PROGRAM = $(INSTALL) -m 755 |
| |
| build: |
| $(checkdir) |
| ./configure |
| make |
| echo timestamp > build |
| |
| clean: |
| $(checkdir) |
| -rm -f build |
| -make distclean |
| -rm -f `find . -name "*~"` |
| -rm -rf debian/tmp debian/files* core debian/substvars conftestdir |
| |
| binary-indep: checkroot build |
| $(checkdir) |
| # There are no architecture-independent files to be uploaded |
| # generated by this package. If there were any they would be |
| # made here. |
| |
| binary-arch: checkroot build |
| $(checkdir) |
| -rm -rf debian/tmp |
| ## make dirs |
| install -d debian/tmp debian/tmp/lib/grub debian/tmp/usr/doc/grub \ |
| debian/tmp/DEBIAN |
| ## install files |
| |
| install -m 644 bin/* debian/tmp/lib/grub |
| |
| # FIXME: gzip the html files, and make sure cross-refs work fine |
| cp -r docs debian/tmp/usr/doc/grub |
| rm -f debian/tmp/usr/doc/grub/docs/COPYING |
| |
| $(INSTALL_DATA) ChangeLog debian/tmp/usr/doc/grub/ |
| gzip -f9 debian/tmp/usr/doc/grub/ChangeLog |
| $(INSTALL_DATA) debian/changelog debian/tmp/usr/doc/grub/changelog.Debian |
| gzip -f9 debian/tmp/usr/doc/grub/changelog.Debian |
| $(INSTALL_DATA) debian/copyright debian/tmp/usr/doc/grub/ |
| |
| dpkg-gencontrol |
| chown -R root.root debian/tmp |
| chmod -R go=rX debian/tmp |
| dpkg --build debian/tmp .. |
| |
| define checkdir |
| test -f debian/rules -a -f shared_src/fsys_ext2fs.c |
| endef |
| |
| # Below here is fairly generic really |
| |
| binary: binary-indep binary-arch |
| |
| checkroot: |
| $(checkdir) |
| test root = "`whoami`" |
| |
| .PHONY: binary binary-arch binary-indep clean checkroot |